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1 Introduction 
 
The iPECS Video/SoftPhone is a multi-media communication terminal using a PC based 
application to link the operation of an on-screen multi-button telephone with other communications 
related PC applications.  iPECS Video/SoftPhone is visualized on the desk-top and interfaced to 
the user via the mouse and keyboard.  All the features of the traditional iPECS multi-button phone 
are available to the user.  A Phone Book database with links to the user’s PIM (Personal Information 
Manager) provides pop-ups for incoming caller identification.  iPECS Video/SoftPhone users can 
employ the Phone Book to place calls as well as manage contact records.  The video interface 
delivers video for a multiparty conference.  The File Sharing feature allows multiple parties in a 
conference to view and manipulate the file.  Other special functions available to iPECS 
Video/SoftPhone users include: appointment scheduling, SMS support, e-mail and call recording. 
 
Features of the iPECS Video/SoftPhone include:  

 Automatic database synchronization 
 Display Mode (Phone/Keyset/Small, Calendar/Keypad) 
 Phone Book calling 
 Phone Book Management 
 Database import/export (MS Outlook, GoldMine, ACT!, Excel) 
 Scheduled Dial 
 User call log 
 User SMS (Short Message Service) 
 Video Conference 
 File Collaboration 
 Voice Recording 
 Local/ Remote Connection Mode 
 Multi-language support 
 E-mail with MS Outlook 
 Flex button labels 
 Incoming Call with Id pop-up window 
 Help 
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2 Installation and setup 
 
Set-up of the iPECS Video/SoftPhone is a four process;  

1. connect the PC to the host iPECS system, 
2.  install the iPECS Video/SoftPhone application on the users’ PC 
3.  install system lock key, and 
4.  complete registration of the Video/SoftPhone application to the iPECS system. 
 

Completing the registration process may require assistance of the iPECS system administrator to 
adjust settings of the iPECS.  For remote applications, the iPECS will require entry of the MAC 
address of the PC running the iPECS Video/SoftPhone.  Also for remote users, the iPECS 
Video/SoftPhone will require entry of the host iPECS system IP address.   
 
Prior to installation, the PC and operating system should be verified for compatibility with the 
iPECS Video/SoftPhone application.  Assure that the PC and OS (Operating System) comply with 
the minimum requirements of sections 2.1 and 2.2. 
 

2.1 System requirements 
 
The minimum requirements for the iPECS Video/SoftPhone PC are described below. 

 Pentium 4 or compatible CPU 
 1 GHz clock speed or higher 
 256 Mbytes RAM  
 200 Mbytes of free hard-drive space 
 1024 x 768 resolution monitor 
 CD-ROM drive 
 Video/Web cam, only required for real-time video 

 

2.2 Supported operating systems 
 
The iPECS Video/SoftPhone application can run under any one of several Microsoft Operating 
Systems including: 

 Microsoft Windows XP 
 Microsoft Windows 2000 
 Microsoft Windows 98 
 Microsoft Windows 98 Second Edition 



  iPECS           Video/SoftPhone Installer & User Guide 

24-Nov-04 2-2 issue 3.0  

 

 

2.3 iPECS Connection 
 
The PC running the Video/SoftPhone application may be connected to the iPECS system either as 
a local or remote device.  The connection as a local device requires the Video/SoftPhone connect 
to the same LAN as the host iPECS system.  When connecting as a remote device, the PC’s MAC 
address must be assigned as a Remote device in the iPECS for proper registration and operation.  
Refer to section 2.6.2 for additional information on remote operation.  Figure 2.3 provides a 
pictorial view of the connections to the iPECS. 

Figure 2.3 iPECS Video/SoftPhone Connections 

 

2.4 Video/SoftPhone Application Installation 
 
When the iPECS Video/SoftPhone CD-ROM is placed in the PC, an auto-execute install program 
will start.  The install Wizard as shown in Figure 2.4a will appear.  
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Figure 2.4a iPECS Video/SoftPhone Install Wizard 

 
In the next installation step, the default destination folder for the Video/SoftPhone application can 
be modified using the Change button.  The default directory for installation is “C:\Program 
Files\iPECS VideoPhone\”, Figure 2.4b.  To continue the installation click the Next> button. 

 
Figure 2.4b Install folder 
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Once the iPECS Video/SoftPhone application has been installed, it is necessary to install 
WinPcap2_3.exe.  You will be asked and must agree to the WinPcap license terms, Figure 2.4c, then 
follow the instructions in the WinPcap and iPECS Video/SoftPhone wizards to complete the 
Video/SoftPhone installation.  

 
Figure 2.4c WinPcap License Window 

 

2.5 iPECS Lock-key  
 
Prior to registration of the iPECS Video/SoftPhone with the host iPECS system, the host iPECS 
system will require installation of the Video/SoftPhone software lock-key.  This is accomplished 
by the iPECS system administrator under the system’s Maintenance window.  The administrator 
should reference the iPECS Admin and Maintenance Manual for guidance. 

 

2.6 Registration 
 

2.6.1 Registration Process 
 

When iPECS Video/SoftPhone is run the first time, it attempts to register with the system.  The 
initial registration, when locally connected, is automatic assuming the iPECS system is set to 
allow registration, refer to the iPECS Description & Installation manual for the Registration 
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Switch settings. 
 
When the iPECS Video/SoftPhone is remotely connected the first time, registration will fail 
unless pre-registered in a local environment.  Such failure may also occur due to use of an 
improper IP address or MAC address, which can be corrected as outlined in section 2.6.2.  When 
this occurs, the host iPECS system IP address must be entered and the connection mode change 
to remote in the Registration Error dialog box, Figure 2.6.2.  Also assure the correct MAC ‘In 
Use’, is displayed in the message window.  
 
For a locally connected device, audio is from point to point over the LAN, NAPT (Network 
Address and Port Translation) is not supported and IPSec is not implemented. For a remotely 
connected device, audio is handled through an iPECS system VoIP channel and remote NAPT is 
supported. 
 
To run the Video/SoftPhone application; 

• select the iPECS Video/SoftPhone shortcut icon (           ), the iPECS Video/SoftPhone 
application will start and attempt to register with the host iPECS system. 

 

2.6.2 Remote Registration Error 
 

If a registration error occurs, the user will receive a Registration Error message and dialog box, 
Figure 2.6.2.  In the dialog box, the user may enter the IP Address for the host iPECS, and 
configure the Video/SoftPhone Connection mode (section 5.3.4) and appropriate MAC for the 
PC.  In certain local environments, the Multicast selection may be available.  To enter 
information in the dialog box; 
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Figure 2.6.2 Registration Error message & dialog box 

 
System IP Address: 

• select New IP Address box, 
• enter new IP Address. 

 
Connection Mode: 

• select Local or Remote radio button. 
 
PC Network Adapter: 

• if the PC has multiple NICs, e.g. wired, wireless, VPN network support, etc., select the 
desired NIC from the drop down menu under In Use MAC. 

 
After changing characteristics in the message box it may be necessary to, 

• select Retry to register, 
• close the iPECS Video/SoftPhone application, 
• restart the application.  
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Registration error messages that may be received include: 
No Response from System –  there is no connection to the host iPECS, the host IP address is 

incorrect, the iPECS is not set for local registration, or the wrong 
NIC (MAC) is being used. 

 
Current Adapter NOT presently Available – the currently defined NIC is in use by another 

application, not connected, or has failed to properly 
connect to the network. 
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3 iPECS Video/SoftPhone Operation 
 

3.1 Overview 
 
iPECS Video/SoftPhone interfaces with the user through the iPECS Video/SoftPhone window, 
Figure 3.1a.  At the top of the Video/SoftPhone window is the Menu bar and below the Menu bar is 
the Video/SoftPhone Tool bar.   
 
There are two Video/SoftPhone views, Phone and Keyset.  The Phone view, Figure 3.1a, emulates 
the basic iPECS phone; an LCD area, keypad and fixed feature buttons are arranged generally as 
with the traditional iPECS phone.  The fixed feature buttons give the user access to features and 
resources of the iPECS with the same displays as the LCD of an iPECS multi-button phone.  The 
user may dial with the mouse from the Keypad window or with numeric keys on the PC keyboard.  
Below the keypad, are the volume control up/down buttons and window selection buttons, Schedule 
and Keypad.  The separate Speaker and Microphone icons may also be used to adjust the volume of 
the microphone or speaker independently with the adjustment slide bar to the right of the icons. 
 

Figure 3.1a Phone view w/Keypad Window  Figure 3.1b Phone view w/Calendar Window 

 
The Keypad window can be toggled to a Schedule window, Figure 3.1b, which links to the user’s 
Outlook appointment scheduler.  The Schedule view includes a scrolling display of daily events 
below the calendar and allows access to the scheduler for managing appointments.  At the bottom of 
the window, the user may access the SMS (Short Message Service) features of the iPECS 
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Video/SoftPhone to exchange short text messages with other users. 
  
The Keyset view, Figure 3.1c, adds the 4 Keyset folders to the right of the Phone view.  The folders 
include Flex Button, PhoneBook, Call Log and Scheduled Dial folders.  The Flex Button folder emulates 
the multi-button function of the traditional 24 button iPECS phone.  The Flex Buttons are used in 
the same manner as the traditional iPECS phone and are fully programmable in the iPECS system 
database.  The iPECS Video/SoftPhone has two Flex button screens for display of 48 Flex buttons.  
The screen displays 24 Flex buttons at a time, displaying buttons 01 to 24 and 25 to 48 by selection 
at the bottom of the screen.  
 

Figure 3.1c iPECS Video/SoftPhone Keyset view 

 
The user’s contact manager can be imported for the PhoneBook folder, displaying information on 
contacts registered in the contact manger database.  The PhoneBook is employed to place calls and 
send e-mails and can be searched, sorted and edited.  The PhoneBook database can be synchronized 
with an external source database each time the iPECS Video/SoftPhone application is run.  Also, 
changes made to the PhoneBook database can be automatically exported to the external database to 
maintain synchronization. 
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The Call Log folder maintains a database with a record of each call placed or received by the iPECS 
Video/SoftPhone.  The Call Log, if enabled, can be viewed, sorted and printed or can be disabled so 
no log records are generated. 
 
In the Scheduled Dial folder the user can input a phone number and a date & time to call the number; 
at the scheduled time the system will confirm and place the requested call. 
 
The iPECS Video/SoftPhone supports Video communications with an automatic link to a standard 
PC camera.  Activate the video camera interface for a preview and open the channel to send real-
time video to the remote party.  More importantly to the business user, files may be shared in a 
collaborative 3 party conference session, each party has access to and can edit the application file, 
over the iPECS Video/SoftPhone link.  From the Tools menu select Application Sharing then, select 
the file.  The file is opened and any of the parties may manipulate the contents in real-time. 
 

3.2 Placing & Receiving Calls 
 

3.2.1 Placing a Call 
 

The basic operation of placing a call for the iPECS Video/SoftPhone is the same as the 
traditional iPECS multi-button phone.  Dialing is accomplished by selecting digits from the 
Keypad window with the mouse or using numeric keys on the PC keyboard. 
 
For internal calls to other iPECS system users; 

• Dial the station number or press a DSS/BLF Flex button.  The digits will display in the 
LCD area. 

• Press the “Space” bar or select the Speaker button with the mouse to terminate the call. 
 
For calls external to the iPECS system; 

• Select a Line button or dial the CO access code (generally ‘9’), 
• Dial the desired number. 
• Press the “Space” bar or select the Speaker button with the mouse to terminate the call. 

 
In addition to the basic calling operation, the user can also place calls by selecting records from 
the Phone Book folder, section 3.5.2, or Call Log folder, section 3.5.3. 
 



  iPECS           Video/SoftPhone Installer & User Guide 

24-Nov-04 3-4 issue 3.0  

 

The iPECS Video/SoftPhone application must be the active application in order to place a call. 
 

3.2.2 Receiving a Call 
 

When a call is received, the phone will ‘ring’ and the Caller Information window will appear 
below the Video/SoftPhone window, Figure 3.2.2.  The window shows the caller id delivered 
from the iPECS system and the name associated from the Phone Book database.  By selecting 
More from the window, the complete Phone Book record will be displayed.  If a call is received 
while the Video/SoftPhone is minimized, the Video/SoftPhone and Caller Information window 
will pop-up to display the incoming call information. 

 
Figure 3.2.2 Caller Information window 

 
To answer the call; 

• Press the “Space” bar or select the SPEAKER button with the mouse. 
• Press the “Space” bar or select the SPEAKER button with the mouse to terminate the call. 
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The iPECS Video/SoftPhone application must be either the active application or minimized to 
the tray in order to receive a call. 
 

3.3 Using iPECS System Features 
 
The iPECS Video/SoftPhone has complete access to all of the system features as well as the 
features available to the traditional iPECS phones, with the few exceptions based on the differences 
in the user platform, refer to section 5.5.  The fixed feature keys operate in the same manner as the 
iPECS phones except the mouse is used to select dial pad and feature buttons.  For operation of the 
features, refer to the iPECS Quick Guide or the iPECS Phone User Guide. 
 

3.4 Appointment Calendar 
 
iPECS Video/SoftPhone Schedule window displays a monthly calendar and a scrolling 
appointment display below the calendar derived from the user’s Outlook scheduler.  By right 
clicking the mouse over a date on the calendar, an Appointment Summary window is displayed over 
the Schedule window, Figure 3.4a. 

Figure 3.4a Appointment Summary in Schedule window 
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The iPECS Video/SoftPhone Schedule window permits on screen access to Outlook scheduler in 
two ways; 

• double click on a date in the Schedule  
or 
• right click the mouse over the calendar date 
• double click on an appointment in the Summary window. 

 
iPECS Video/SoftPhone will call the Outlook Scheduler so that the user can add or modify an 
appointment in the Scheduler edit box, Figure 3.4b. 

 
Figure 3.4b Outlook Scheduler edit window 

• enter a new or edit an existing appointment following Outlook instructions.  When 
complete save and close the Appointment, this will save the file in the Outlook database 
and automatically update the iPECS Video/SoftPhone Schedule database. 

 
When browsing the Calendar, the user may return to the current date display by clicking the 
Today button next to the month/year display in the Schedule window, Figure 3.4c. 
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Figure 3.4c Today button in Schedule window 

 

3.5 Keyset Folder Operation 
 
The Keyset view adds the 4 Keyset folders including the Flex Btn (Flexible or Flex Button), 
PhoneBook, Call Log and Schedule Dial folders to the right side of the Phone view, Figure 3.5.  The 
separate folders are accessed by selecting the folder tab at the top of the Keyset folder window. 
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Figure 3.5 Keyset view 

 
A PhoneBook database can also be opened from the File menu, section 5.1.  Once accessed from the 
File menu, operation in the folder is the same as described in the following sections.  
 

3.5.1 Flex Btn Folder 
 

The Flex Btn folder provides access to “48 Flex buttons’ in two windows, FLEX 1-24 and FLEX 
25-48.  Flex button windows display a 4 by 6 array of ‘Flex buttons’, total of 24, Figure 3.5.1.  
Each button includes a status icon, which displays the status of the CO Line or station associated 
with the button.  The button also displays a designation from the iPECS system database, such 
as CO 001, SPD 001, etc.  A further label, which will be displayed in the button, can be assigned 
by the Video/SoftPhone user under the Program menu, section 5.2.2. 
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Figure 3.5.1 Flex Btn Folder 

 
Selecting a Flex button with the mouse will access a CO line, call a station, or activate a feature 
based on the function assigned to the Flex Button in the iPECS system database. 

 

3.5.2 PhoneBook Folder 
 

iPECS Video/SoftPhone maintains a PhoneBook database, Figure 3.5.2a, of the users’ contacts, 
both other iPECS users and external contacts.  The user can place calls and send e-mails to 
contacts selected from the database employing the search, sort and record management tools in 
the PhoneBook Tool bar.  When a record is added, edited or deleted in the PhoneBook, the 
Video/SoftPhone can also update (synchronize) the original source database, refer to section 
5.1.1. 
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Figure 3.5.2a PhoneBook Folder with Call window 

 
To call a number from the PhoneBook; 

• right click on the desired record, see search & sort below, and 
• click the icon from the Call window: Dial, Transfer, Conference or Scheduled Dial. 

or 
• select the desired record and, 
• click the Dial icon from the PhoneBook Tool bar. 

or 
• double click on the desired record or phone number field. 

 
To send an e-mail from the database; 

• select the desired record(s), 
• select the e-Mail icon from the PhoneBook Tool bar, the Outlook e-mail program is called 

and loaded with the selected recipients, 
• type in subject, message, and send the e-mail. 
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To search the PhoneBook database; 
• key in alphanumeric string in the search box. 

 
To sort records in the PhoneBook; 

• Click on the header field at the top of the PhoneBook to sort alphabetically/numerically, 
click again for reverse order. 

 
To add or edit a record; 

• select desired record for edit, 
• click the add or edit icon to view the Contact Record form, Figure 3.5.2b, 
• key entries for available fields.  Fields include: 

 * Name, required field 
 Multiple Phone Numbers  
 E-mail address 
 Company information 
 Address 
 Note  
 Image, to remove an image from the contact record, right click on the image to view 

the Clear Image pop-up dialog box.  Select Clear Image and OK. 
• Select OK to save the record in the PhoneBook and synchronize the source database. 

 

Figure 3.5.2b Contact Record Form 

 
To delete a record; 

• select the desired record(s), 
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• click the delete icon in the PhoneBook Tool bar, the Confirmation window, Figure 3.5.2c will 
appear, 

• confirm to remove the record(s). 

 

Figure 3.5.2c Delete Confirmation window 

 

3.5.3 Call Log Folder 
 

The Call Log folder, Figure 3.5.3, provides a log of all calls placed or received by the iPECS 
Video/SoftPhone.  If Call Log is enabled under the File menu, each call, initiated or received, 
will generate a record which will contain information on the call as well as data derived from the 
PhoneBook.  Once the call is completed, a record is stored in the Call Log database.  The record 
will contain the following fields: 

 Date & Time: date and time of the call from the user’s PC 
 Name: name of connected party from the PhoneBook 
 Phone: the called or calling party phone number, from the iPECS or carrier 
 Call Type: type of call, incoming/outgoing and answer/no answer 
 Duration: duration the call was connected in hours, minutes and seconds 
 Note: note entered by user 
 Company: from the PhoneBook 
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Figure 3.5.3 Call Log Folder 

 
The Tool bar at the top of the logs, allows the user to place a call and manage the Call Log 
database.  To place a call from the Call Log; 

• Double click on the record to place the call  
or 
• select a record, 
• click the Dial icon, iPECS Video/SoftPhone will place a call to the phone number of 

record.  
 

To store the Call Log; 
• click the Save icon.  The familiar Save As dialog box will appear, select a folder, if other 

than iPECS Video/SoftPhone, 
• enter the filename 
• select Save.  The file is saved in an *.xls format for easy future access and all records in 

the Call Log folder are deleted. 
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To add or edit a note or name to a record; 
• click the Edit icon, 
• type the note or name in the edit dialog box, 

 

• Select OK to save in the Call Log.  Although all the fields of the call record are shown in 
the Edit dialog box only the Note and Name field can be edited and the Note field 
supports up to 250 characters. 

 
To copy a record to the PhoneBook or Scheduled Dial database; 

• right click on the desired record 
• click the Add to the Phone Book or Add to the Scheduled Dial selection. 

 
Selecting the Delete icon will remove the selected record(s) and selecting the Del All icon will 
delete all records in the Call Log.  In both cases, the user is asked to confirm the record deletion. 
 

3.5.4 Scheduled Dial Folder 
 

Scheduled Dialing permits the user to enter a phone number for dialing at a later scheduled time.  
When the scheduled time is reached, the Dial Confirmation window, Figure 3.5.4a, will appear and 
must be confirmed by the user before dialing will begin. 
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Figure 3.5.4a Dial Confirmation window 

 
The Scheduled Dial folder, Figure 3.5.4b contains a list of the phone numbers and schedules 
entered by the user.  The folder Tool bar permits the user to manage the Scheduled dialing feature.  

 

Figure 3.5.4b Schedule Dial folder 

 
To add or edit a Schedule Dial; 

• click the Add or Edit button on the Schedule Dial Tool bar icon and the Schedule Dial dialog 
box, Figure 3.5.4c appears, 
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• click the calendar to input the date, date is a required entry, 
• select the time (in 24 hour mode) from drop down selection menu, time is a required 

entry, 
• input or edit the telephone number, the telephone number is a required entry, 
• input or edit name, 
• select OK to save the schedule and number for later dialing.  A date, time and number 

must be entered. 

 
Figure 3.5.4c Schedule Dial dialog box 

 
To delete an entry from the Scheduled Dial folder; 

• select Delete to remove the record.  The user will be asked to confirm the record deletion. 
 

3.6 SMS (Short Message Service) 
 
SMS (Short Message Service), which is typically provided in GSM mobile networks, is a service 
permitting users to share (send and receive) text messages with other users.  A text message is 
comprised of an alphanumeric combination of up to 100 characters.  When an SMS message is 
received, the Message Wait indication will activate and the user’s iPECS Video/SoftPhone or 
display phone, can review the received message.  The iPECS Video/SoftPhone can maintain up to 
ten received messages after which, new messages are ignored. 
 
To send a text message to other users; 

• enter the message in the SMS window, Figure 3.6a, 
• select Send To in the SMS window, the Recipient window, Figure 3.6b, appears, 
• select the desired recipients with the check boxes or range (From & To) boxes, 
• select Send, the message is delivered. 
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Figure 3.6a SMS window 

 

 
Figure 3.6b SMS Recipient window 

 
To review received SMS messages, the MSG/CB button will flash; 

• select the flashing MSG/CB button, the SMS Receive window with a radio button for each 
SMS message will appear, Figure 3.6c, 

• select the desired radio button, 
• select Delete to remove the message. 

 

Figure 3.6c SMS Receive window 
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4 iPECS Video/SoftPhone Tool Bar Operation 
 

4.1 Phone Views 
 
iPECS Video/SoftPhone provides the user with a visual representation of a Phone on the desk-top.  
There are two views for the Video/SoftPhone, Phone and Keyset.  The Phone view emulates the 
appearance of the traditional iPECS phone displaying an LCD area, keypad and fixed feature 
buttons.  The Keyset view adds the Keyset folders window.  This window has 4 tabbed folders; the 
Flex Btn folder with two arrays of 24 Flex buttons each, the PhoneBook folder displays the user’s 
Phonebook, the Call Log folder displays records for each call placed or received by the 
Video/SoftPhone, and the Scheduled Dial folder, which permits the user to assign a phone number 
for dialing at a scheduled time. 
 
The view is controlled by the Phone/Keyset icon at the far left of the Video/SoftPhone Tool bar, 
Figure 4.1.  When selected, the Video/SoftPhone view will toggle between the Phone and Keyset 
views. 

Figure 4.1 Phone/Keyset Tool bar icon 

 

4.2 Video Operation 
 
With the iPECS Video/SoftPhone, the user can access the PC’s default video cam application to 
send and receive real-time video of the connected party.  Access to the video application is 
controlled by the Video icon on the Video/SoftPhone Tool bar, Figure 4.2a or the Video item in the 
Tools Menu, section 5.3.1. 

Figure 4.2a Tool bar Video icon 

 
After selecting the Video icon, select the       (start) button in the Multi-Media Comms screen to 
begin real-time video transmission, Figure 4.2b. 
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Figure 4.2b Multi Media Comms screen 

 
Tools available in this application include start transmit, stop transmit, video attributes, frame rate, 
receive video size (up to 2 x) and close. 
 
A text channel is also opened for Chat as well as voice and video communications.  The Chat thread 
is shown in the Chat window. 
 

4.3 Record Operation 
 
iPECS Video/SoftPhone allows the user to record an active conversation to the PC’s hard disk.  
Recording is controlled using the Record icon on the Video/SoftPhone Tool bar, Figure 4.3 or the 
Voice Record item in the Tools menu, section 5.3.3. 

• Select the Record icon to start recording, 
• select the icon again to stop recording, 
• when the recording is complete, Video/SoftPhone will ask the user for a filename to use for 

storing the recording. 
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Figure 4.3 Tool bar Voice Record icon 
 
iPECS Video/SoftPhone generates a single “record-start” tone; you should notify other parties to 
any recording.  Playback and management of recorded voice files is accomplished under the Tools 
menu Voice Record item, section 5.3.3. 
 

4.4 Exit  
 
The user may terminate the iPECS Video/SoftPhone application using the Exit icon on the Tool bar, 
Figure 4.4. 

Figure 4.4 Tool bar Exit icon 
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5 Menu Bar Operation 

5.1 File Menu 
 
The File menu gives access to the PhoneBook and Call Log database management functions. 
 

5.1.1 PhoneBook 
 

Selecting Phone Book from the File menu will present the Phone Book menu where the user may 
manage the PhoneBook database, Figure 5.1.1.  From this menu, the user may select to open a new 
or existing database, save a database, import or export a database or maintain synchronization with 
an external database.  Once a PhoneBook is opened, operation of the folder is the same as discussed 
in section 3.5.2. 

 
Figure 5.1.1 Phone Book Menu 
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The user may open a new blank database for use with the PhoneBook folder; 
• select New from the menu, 
• select a folder location, 
• enter a filename. 

 
The user may select the database to employ for the PhoneBook folder.  Once selected, the selected 
database name will appear on the PhoneBook folder tab and the database is used for iPECS 
Video/SoftPhone PhoneBook until a new selection is made by the user.  To open a selected 
database; 

• select Open from the menu, 
• select a database.  The file format of the database must be consistent with the *.DB file format 

of the iPECS Video/SoftPhone database; other file type selections will receive a warning 
message. 

 
Various contact manager applications employ different data formats.  To permit use of common 
formats, iPECS Video/SoftPhone allows the user to import databases from Outlook, GoldMine, 
and ACT! or Excel applications.  When imported, the database format is modified to match the 
PhoneBook database and displayed in the PhoneBook folder.  To import a database; 

• select Import from the Phone Book menu, 
• select the application type, Outlook, Gold Mine, ACT! or Excel, 
• select the database. 

 
The user may save a copy of the PhoneBook database as a back-up copy or for future use.  To save a 
copy of a database; 

• select Save As… from the Phone Book menu, 
• select a folder, if different than the iPECS Video/SoftPhone folder, 
• select the filename, 
• select Save. 

 
The PhoneBook database can be exported for use in other applications including Outlook, Gold Mine, 
and ACT! or Excel.  To export a PhoneBook database; 

• select Export from the Phone Book menu, 
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• select the application type, Outlook, Gold Mine, ACT! or Excel, 
• select the database. 

 
The PhoneBook can be synchronized with an external Outlook, Gold Mine or ACT! database 
automatically.  When synchronized, each time the iPECS Video/SoftPhone is started it will use the 
external database as the PhoneBook and will update the external database after any changes in the 
PhoneBook.  To enable automatic synchronization, 

• select Sync DB from the Phone Book menu, 
• select the application type, Outlook, Gold Mine, ACT! or Excel, 
• select the database. 

 
Note that changes made directly to an external database are not effective in an active iPECS 
Video/SoftPhone.  Such changes require a restart of the iPECS Video/SoftPhone application to 
update the active PhoneBook database. 
 

5.1.2 Call Log  
 

Selecting Call Log from the File menu will display the Call Log menu, Figure 5.1.2.  From the Call 
Log menu, the user may enable or disable the Call Log function. 
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Figure 5.1.2 Call Log menu 

 

5.2 Program Menu 
 
Selecting the Program Menu accesses iPECS Video/SoftPhone settings and the users e-mail program.  
The user can set different ring signals, establish dialing rules and enter Flex data labels, as well as 
access their e-mail program through the Program menu, refer to Figure 5.2. 
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Figure 5.2 Program Menu 

5.2.1 e-Mail 
 

With the iPECS Video/SoftPhone, the user can access the Outlook e-mail application to send ad 
hoc e-mails.  Access to the e-mail application is provided by the e-Mail item in the Program menu, 
which, when select, will call the Outlook e-mail application.  The e-mail application can also be 
called from the or from the PhoneBook folder section 3.5.2. 
 

5.2.2 Flex Data  
 

In the Flex Btn folder, each button is displayed with a status icon and a designation provided to the 
Video/SoftPhone by the iPECS system, refer to section 3.5.1.  For convenience, the user can enter 
a label that will be shown in the lower portion of the button.  To assign Flex button labels; 

• select the Flex Data item from the Program menu, the Flex Data window, Figure 5.2.2a, will 
appear, 
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Figure 5.2.2a Flex Data Window 

 

• select the desired Flex button (FLEX 1 to FLEX 24) label field, 
• type in the desired label, up to 12 characters, 
• click OK, 

• repeat for additional Flex buttons 
• when complete, select Left or Right in the Layout box to align the label to the left or right in the 

Flex button, 
• click on the Close icon to return to the iPECS Video/SoftPhone screen, the new labels will be 

shown in the Flex Btn folder, 5.2.2b. 
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Figure 5.2.2b iPECS Video/SoftPhone screen with Flex Data labels 

 

5.2.3 Dialing Rules 
 

When the user places an outside call from the PhoneBook or Call Log folder, the iPECS 
Video/SoftPhone must include certain dial codes to assure proper dialing through the iPECS 
system.  When a number is selected from either database, the system will determine the type of call 
and insert any CO Access Code, LD Access Code or International Access Code required for the host 
iPECS to properly establish the call.  Codes are entered in the Dialing Rules dialog box, Figure 5.2.3, 
along with local codes for comparison.  To enter codes; 

• select Dialing Rules from the Program menu, 
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• enter the various codes, 
• select OK. 

 

Figure 5.2.3 Dialing Rules dialog box 

 

5.2.4 Differential Ring 
 

The iPECS Video/SoftPhone can provide one of 4 different ring signals with separate assignments 
for internal and external calls.  Each of the 4 ring signals is contained in a *.wav file.  The user may 
select one of the 4 predefined *.wav files (ring1.wav, ring2.wav, ring3.wav and ring4.wav) or may 
replace any of these files with a desired *.wav or *.mp3 file. 
 
Selecting Program > Differential Ring displays the Ring tone files window, Figure 5.2.4.  To change a 
Ring tone file, 

• select the change icon next to file to be replaced, 
• select the desired *.wav or *.mp3 file from the PC’s file system, and 
• select Change, 

• close the Ring tone files window and the new file may be selected for use. 
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Figure 5.2.4 Ring tone files window 

 
To select a Ring Tone for use; 

• click the PGM fixed feature button, 
• dial 1 for Ring Tone Selection, 
• dial 1 for Intercom Ring or 2 for CO/IP ring, 
• dial desired Ring Tone (1-4), a short burst of the tone is generated, 
• press SAVE. 

 

5.3 Tools Menu 
 
Selecting the Tools Menu various tools and applications are accessed.  Real-time video, collaborative 
program sharing, voice recording, and other tools are accessed through the Tools menu, refer to Figure 
5.3. 
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Figure 5.3  Tools Menu 

 

5.3.1 Video 
 

The iPECS Video/SoftPhone will employ the user’s PC cam and application to implement real-time 
video communications over an IP based network.  The real-time video supports transport of H.263 
and MPEG 4 standard video codecs.  The frame rate may be increased to 15-frames/second but 
packet loss and delay may become excessive and lower frame rates may perform better with other 
services.  The video channel also opens a separate “chat” channel for text communication as well as 
video and voice for multi-media communications. 
 
Selecting Tools > Video displays the Video preview screen, which may also be accessed from the 
Video/SoftPhone Tool bar, refer to section 4.2. 
 
To open the video channel; 

• select the         (start) button, and video is sent to the far end user.  Text may be input in the /         
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text entry box and a chat thread is displayed in the CHAT area as shown in Figure 5.3.1.  
Tools available in this application include start transmit, stop transmit, video attributes, frame 
rate, receive video size (up to 2 x) and close. 

Figure 5.3.1 Multi-media Comms Screen 
 

5.3.2 File Collaboration 
 

iPECS Video/SoftPhone users can share file applications over the iPECS RTP connection.  Any 
active or minimized file can be viewed and manipulated by all parties.  Control over the file and 
application can be shared for a collaborative session handling presentations, drawings, documents, 
etc. 
 
Selecting Tools > Program Share displays the Program selection window, Figure 5.3.2a.  The Program 
selection window displays files available for collaborative sharing.  Only active or minimized files 
can be accessed by the iPECS Video/SoftPhone sharing application.  
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Figure 5.3.2a Program Selection Window 
 
To share an application file; 

• select the file in the Program selection window and select .  This will 
transmit the application file to the connected parties, refer to Figure 5.3.2b. 



  iPECS           Video/SoftPhone Installer & User Guide 

24-Nov-04 5-13 issue 3.0  

 

Figure 5.3.2b Application Sharing 

 
The Application sharing window includes a Menu bar at the top.  When a user is given control, the 
text “Control” turns to a red color.  The connected party may be allowed control for input and locally 
storing the file.  To shift the controlling user; 

• select “Hand over Control”. 

• select the radio button for the desired user, the “Control” text in the upper menu bar turns to 
a red color. 

 
Files are sent by the controller to the other party periodically.  The interval is adjustable in 1/10th of a 
second (100 msec) increments from 0.1 to 10.0 seconds, 0.5 seconds generally appears acceptable for 
most collaborative work while longer periods are acceptable for reviews.  To adjust the interval; 
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• select the transmit Interval drop-down menu 
• select the desired 1/10th of a second interval. 

 

5.3.3 Voice Record 
 

iPECS Video/SoftPhone permits recording of a conversation onto the PC’s hard drive.  Recorded 
conversations can be reviewed after recording.  In addition, a voice memo can be added to the 
recording and the recording with memo sent by e-mail as attached *.wav files. 
 
Selecting Tools > Voice Record displays the Record/Play selection menu.  Selecting Record while in a 
conversation will activate the recording function; recording both sides of the iPECS 
Video/SoftPhone conversation.  Recording may also be activated from the Video/SoftPhone Tool 
bar, refer to section 4.3.  iPECS Video/SoftPhone sends a single “record-start” tone; you should 
notify the other parties to any recording. 

 
Selecting Play will show a list of recorded files in the Playback window, Figure 5.3.1.  The window 
includes playback controls for playing a selected file.  The user may delete a file, record a comment, 
and/or e-mail the recording using the Playback window controls. 

 

 
Figure 5.3.1 Recorded Files & Playback Window & Controls 

 

5.3.4 Connection Mode 
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iPECS Video/SoftPhone can be registered to an iPECS system in Local or Remote Mode.  In the 
Remote Mode, iPECS allocates a VoIP channel to support the call.  The VoIP channel implements 
NAPT (Network Address & Port Translation) compatibility and packet forwarding to internal 
appliances. 
 
Selecting Tools then Connection Mode will display the Local/Remote selection window with the 
present mode checked.  When either mode is selected, which is done with the mouse, the iPECS 
Video/SoftPhone will terminate and re-connect with the host iPECS system to establish the 
selected connection mode. 
 

5.3.5 Date Format 
 

The format used for the date display of the PhoneBook, Call log and Scheduled Dial folders can be 
changed from day/month/year to month/day/year.  Selecting Tools then Date Format will display the 
format selection window with the present selection checked.  Click the desired Date Format in the 
menu. 
 
The date display for the iPECS Video/SoftPhone LCD area is controlled by the iPECS system and 
may be different from the selected Date Format.  
 

5.3.6 Language   
 

The iPECS Video/SoftPhone supports two languages, English and Local Language.  The Local 
Language is translated from English and edited into the ‘language.txt’ file located in the iPECS 
Video/SoftPhone directory.  For additional help, access the ‘language.txt’ text file in the iPECS 
Video/SoftPhone folder. 
 
Selecting Tools then Language, will display the English/Local Language selection window with the 
present mode checked.  After selecting the desired language you must restart the iPECS 
Video/SoftPhone application.  Also, if any changes are made to the language.txt file, restart iPECS 
Video/SoftPhone to load the changes in the Video/SoftPhone’s active memory. 
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5.3.7 Audio Controls 
 

The Video/SoftPhone can control the audio input/output device employed.  The device for audio 
input and output is selected in the Audio Device Controls screen, figure 5.3.7.  The audio output 
device (received audio) can be defined separately for voice and ring signals.  Selecting the Audio 
device drop-down menu will display the device choices available. 

Figure 5.3.7 iPECS Video/SoftPhone Audio Device Controls screen 
 

5.3.8 Minimize 
 

When the iPECS Video/SoftPhone application is executed, a tray icon is created, Figure 5.3.8a.  
When the application is “minimized”, the iPECS Video/SoftPhone icon is moved to the desk-top 
tray.  In this way, the application does not clog the program tray. 

Figure 5.3.8a iPECS Video/SoftPhone Desk-top Tray icon 

 
To restore the iPECS Video/SoftPhone; 

• click the tray icon, 
or 
• ‘right-click’ with the mouse pointer on the icon and  
• select Show or Exit from the pop-up menu. 
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Figure 5.3.8b iPECS Video/SoftPhone Desk-top Tray Menu 

 

5.4 Help Menu 
 

5.4.1 Help 
 

The iPECS Video/SoftPhone Help yields a wealth of information on the operation of the 
Video/SoftPhone specific features as well as standard iPECS station features available to the 
Video/SoftPhone.  To access the Help menu, select the Help item from the menu or press the “F1” 
key. 
 
The iPECS Video/SoftPhone Help window, Figure 5.4.1, appears showing major topics covered 
for the iPECS Video/SoftPhone.  Additional topics are available under the Help Topics menu and 
include operation of standard iPECS user features. 
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Figure 5.4.1 Help Window 

 

5.4.2 About 
 

The About item from the Help menu displays the version, IP address, MAC address, and connection 
mode for the iPECS Video/SoftPhone, Figure 5.4.2. 
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Figure 5.4.2 Help Menu About screen 

 

5.5 iPECS Video/SoftPhone User Programming 
 
As previously noted, the iPECS Video/SoftPhone operates in the same manner as the traditional 
iPECS phone.  There are however several user programmable functions which are not supported due to 
differences in the platform, i.e. PC versus iPECS Phone.  The user programmable functions not 
supported by the Video/SoftPhone include: 

Station Answer mode, iPECS Video/SoftPhone does not support Intercom Call Announce 
and, thus supports only Privacy for the Station Answer mode. 
Station Ring Download, iPECS Video/SoftPhone can not download ring tone files from the 
iPECS system, the Video/SoftPhone user can change the ring tone files stored in the iPECS 
Video/SoftPhone folder, see section 5.2.4. 
Audio source control, iPECS Video/SoftPhone has a single audio path and thus can not 
support the dual path (headset and speaker) controls available with the traditional iPECS 
phone. 

 
 


